• Ελληνικά
  • Basket (0)
 

Internet for your laptop & tablet



Necessary upgrade for ALL Κ4505 and Κ4505-Ζ (28.8Mbps) devices

Upgrade now:

 

 

 

Software updates

 

 

pc

Minimum system requirements (PC):

 

My PC needs to have:

  • Windows 7 (32 bit & 64 bit),Vista (32 bit & 64 bit, SP2), Windows XP (SP3) (the operating system edition can be seen by right clicking on the "My Computer" icon and selecting "Properties".)
  • More than 512 ΜΒ of RAM, 1GHz processor

 



 

pc

Minimum system requirements (MAC):

 

In the case of an Apple MAC Version 4.07, the following conditions should be met:

  • •OS X 10.5.8 Leopard or newer version


 
Attention
NO OTHER operating systems, like Win95, Win98 First Edition ή Second Edition, Windows NT (all editions), Windows Millennium (ME), Linux (all editions) are supported.